»查看更多分類股票軟件

上下亂求索1☆ 簡睿震譜{源碼 主圖}

發布時間:2019-02-23 11:16:00  點擊:

只是自身求索觀點留薦貼!留印交流而已
   歷史是當下的最好借鑒!
   所以我對前期股價的高低點所蘊含對后期股價區間的影響作了些自以為是的胡亂思索!


期高低點所衍生對后期股價的支撐帶與壓力帶!但只是一種直線的延伸,沒有對后期股價運行時間作任何意義上的注入!
   引入弧形對直線作運行時間的簡單固定頻率注入!


波:=73;
NA:=25;

NC:=3; NB:=IF(NA>10,10,NC);
CURR:=CURRBARSCOUNT; SS:=PERIOD;
AA:=REF(H,NA)=HHV(H,2*NA+1);
QY:=BACKSET(AA,NA+1);
CC:=FILTER(QY,NA) AND H=HHV(H,NA+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURR,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{頂部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
AA1:=REF(L,NA)=LLV(L,2*NA+1);
QY1:=BACKSET(AA1,NA+1);
CC1:=FILTER(QY1,NA) AND L=LLV(L,NA+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURR,0);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
LAA:=REF(H,NB)=HHV(H,2*NB+1);
LQY:=BACKSET(LAA,NB+1);
LCC:=FILTER(LQY,NB) AND H=HHV(H,NB+1);
LDDD:=BARSLAST(LCC);
LGDTS:=IF(LCC,CURR,0);
LDINGBU:=IF(LDDD,REF(H,LDDD),H);{頂部}
LDINGBUTS:=IF(LDDD,REF(LGDTS,LDDD),LGDTS);
LDINGBU1:=REF(LDINGBU,LDDD+1);
LGDCS1:=CONST(LDINGBUTS);
LDINGBUTS1:=REF(LDINGBUTS,LDDD+1);
LGDCS2:=CONST(LDINGBUTS1);
LAA1:=REF(L,NB)=LLV(L,2*NB+1);
LQY1:=BACKSET(LAA1,NB+1);
LCC1:=FILTER(LQY1,NB) AND L=LLV(L,NB+1);
LDD1:=BARSLAST(LCC1);
LDDTS:=IF(LCC1,CURR,0);
LDDTS1:=IF(LDD1,REF(LDDTS,LDD1),LDDTS);
LDDCS1:=CONST(LDDTS1);
LDDTS2:=REF(LDDTS1,LDD1+1);
LDDCS2:=CONST(LDDTS2);
LLAA:=REF(H,NC)=HHV(H,2*NC+1);
LLQY:=BACKSET(LLAA,NC+1);
LLCC:=FILTER(LLQY,NC) AND H=HHV(H,NC+1);
LLDDD:=BARSLAST(LLCC);
LLGDTS:=IF(LLCC,CURR,0);
LLDINGBU:=IF(LLDDD,REF(H,LLDDD),H);{頂部}
LLDINGBUTS:=IF(LLDDD,REF(LLGDTS,LLDDD),LLGDTS);
LLDINGBU1:=REF(LLDINGBU,LLDDD+1);
LLGDCS1:=CONST(LLDINGBUTS);
LLDINGBUTS1:=REF(LLDINGBUTS,LLDDD+1);
LLGDCS2:=CONST(LLDINGBUTS1);
LLDINGBU2:=REF(LLDINGBU1,LLDDD+1);
LLAA1:=REF(L,NC)=LLV(L,2*NC+1);
LLQY1:=BACKSET(LLAA1,NC+1);
LLCC1:=FILTER(LLQY1,NC) AND L=LLV(L,NC+1);
LLDD1:=BARSLAST(LCC1);
LLDDTS:=IF(LLCC1,CURR,0);
LLDDTS1:=IF(LLDD1,REF(LLDDTS,LLDD1),LDDTS);
LLDDCS1:=CONST(LLDDTS1);
LLDDTS2:=REF(LLDDTS1,LLDD1+1);
LLDDCS2:=CONST(LLDDTS2);
長G1:=CONST(DRAWLINE(CURR=GDCS1,H,REF(CURR,1)=GDCS1,REF(H,1),1));
長G2:=CONST(DRAWLINE(CURR=GDCS2,H,REF(CURR,1)=GDCS2,REF(H,1),1));
長D1:=CONST(DRAWLINE(CURR=DDCS1,L,REF(CURR,1)=DDCS1,REF(L,1),1));
長D2:=CONST(DRAWLINE(CURR=DDCS2,L,REF(CURR,1)=DDCS2,REF(L,1),1));
中G1:=CONST(DRAWLINE(CURR=LGDCS1,H,REF(CURR,1)=LGDCS1,REF(H,1),1));
中G2:=CONST(DRAWLINE(CURR=LGDCS2,H,REF(CURR,1)=LGDCS2,REF(H,1),1));
中D1:=CONST(DRAWLINE(CURR=LDDCS1,L,REF(CURR,1)=LDDCS1,REF(L,1),1));
中D2:=CONST(DRAWLINE(CURR=LDDCS2,L,REF(CURR,1)=LDDCS2,REF(L,1),1));
短G1:=CONST(DRAWLINE(CURR=LLGDCS1,H,REF(CURR,1)=LLGDCS1,REF(H,1),1));
短G2:=CONST(DRAWLINE(CURR=LLGDCS2,H,REF(CURR,1)=LLGDCS2,REF(H,1),1));
短D1:=CONST(DRAWLINE(CURR=LLDDCS1,L,REF(CURR,1)=LLDDCS1,REF(L,1),1));
短D2:=CONST(DRAWLINE(CURR=LLDDCS2,L,REF(CURR,1)=LLDDCS2,REF(L,1),1));
短G:=CONST(FINDHIGH(H,0,5,1));
短D:=CONST(FINDLOW(L,0,5,1));
XAM:=CONST(MAX(MAX(MAX(MAX(MAX(長G1,H),MAX(長G2,H)),MAX(MAX(中G1,H),MAX(中G2,H))),
MAX(MAX(短G1,H),MAX(短G2,H))),MAX(短G,H)));
XIM:=CONST(MIN(MIN(MIN(MIN(MIN(長D1,L),MIN(長D2,L)),MIN(MIN(中D1,L),MIN(中D2,L))),
MIN(MIN(短D1,L),MIN(短D2,L))),MIN(短D,L)));
低天:=IF(長D1=XIM,DDCS1,IF(長D2=XIM,DDCS2,IF(中D1=XIM,LDDCS1,
IF(中D2=XIM,LDDCS2,IF(短D1=XIM,LLDDCS1,IF(短D=XIM,BARSLAST(短D=XIM)+1,LLDDCS2))))));
高天:=IF(長G1=XAM,GDCS1,IF(長G2=XAM,GDCS2,IF(中G1=XAM,LGDCS1,
IF(中G2=XAM,LGDCS2,IF(短G1=XAM,LLGDCS1,IF(短G=XAM,BARSLAST(短G=XAM)+1,LLGDCS2))))));
高低距:=CONST(XAM)-CONST(XIM);
天距:=(IF(高天>低天,高天,低天)-IF(高天>低天,低天,高天));
PR:=IF(高天>低天,高天,低天);
RN:=IF(高天>低天,CONST(XAM),CONST(XIM));
BX:=230/天距; BY:=100/高低距;
XW:=IF(CURR<PR,PR-CURR,CURR-PR)*BX;
Y弧:=波;
高低:=DRAWLINE(CURR=高天,XAM,CURR=低天,XIM,0);
低高:=DRAWLINE(CURR=低天,XIM,CURR=高天,XAM,0);
高低線:=IF(高天>低天,高低,低高),COLOR8E2368,LINETHICK2;
DRAWBAND(高低線,RGB(125,26,199),高低線,RGB(125,26,199));
距線1:=DRAWLINE(CURR=高天,XIM,CURR=低天,XIM,0);
距線2:=DRAWLINE(CURR=低天,XIM,CURR=高天,XIM,0);
STICKLINE(CURR=高天,XIM,XAM,0,0),COLOR8E2368;
距線:=IF(高天>低天,距線1,距線2),COLOR8E2368,LINETHICK2;
DRAWBAND(距線,RGB(125,26,199),距線,RGB(125,26,199));
YWA:=IF(XW<Y弧,SQRT(Y弧*Y弧-XW*XW)/10,0)/BY;
圓弧A:=IF(高天<低天,RN+YWA,RN-YWA),COLORYELLOW;
DRAWBAND(圓弧A,RGB(255,196,9),圓弧A,RGB(255,196,9));
YWB:=IF(XW<2*Y弧,SQRT(2*Y弧*2*Y弧-XW*XW)/10,0)/BY;
圓弧B:=IF(高天<低天,RN+YWB,RN-YWB),COLORYELLOW;
DRAWBAND(圓弧B,RGB(255,196,9),圓弧B,RGB(255,196,9));
YWC:=IF(XW<3*Y弧,SQRT(3*Y弧*3*Y弧-XW*XW)/10,0)/BY;
圓弧C:=IF(高天<低天,RN+YWC,RN-YWC),COLORYELLOW;
DRAWBAND(圓弧C,RGB(255,196,9),圓弧C,RGB(255,196,9));
YWD:=IF(XW<4*Y弧,SQRT(4*Y弧*4*Y弧-XW*XW)/10,0)/BY;
圓弧D:=IF(高天<低天,RN+YWD,RN-YWD),COLORYELLOW;
DRAWBAND(圓弧D,RGB(255,196,9),圓弧D,RGB(255,196,9));
YWE:=IF(XW<5*Y弧,SQRT(5*Y弧*5*Y弧-XW*XW)/10,0)/BY;
圓弧E:=IF(高天<低天,RN+YWE,RN-YWE),COLORYELLOW;
DRAWBAND(圓弧E,RGB(255,196,9),圓弧E,RGB(255,196,9));
YWF:=IF(XW<6*Y弧,SQRT(6*Y弧*6*Y弧-XW*XW)/10,0)/BY;
圓弧F:=IF(高天<低天,RN+YWF,RN-YWF),COLORYELLOW;
DRAWBAND(圓弧F,RGB(255,196,9),圓弧F,RGB(255,196,9));
YWG:=IF(XW<7*Y弧,SQRT(7*Y弧*7*Y弧-XW*XW)/10,0)/BY;
圓弧G:=IF(高天<低天,RN+YWG,RN-YWG),COLORYELLOW;
DRAWBAND(圓弧G,RGB(255,196,9),圓弧G,RGB(255,196,9));
YWH:=IF(XW<8*Y弧,SQRT(8*Y弧*8*Y弧-XW*XW)/10,0)/BY;
圓弧H:=IF(高天<低天,RN+YWH,RN-YWH),COLORYELLOW;
DRAWBAND(圓弧H,RGB(255,196,9),圓弧H,RGB(255,196,9));
YWI:=IF(XW<9*Y弧,SQRT(9*Y弧*9*Y弧-XW*XW)/10,0)/BY;
圓弧I:=IF(高天<低天,RN+YWI,RN-YWI),COLORYELLOW;
DRAWBAND(圓弧I,RGB(255,196,9),圓弧I,RGB(255,196,9));
YWJ:=IF(XW<10*Y弧,SQRT(10*Y弧*10*Y弧-XW*XW)/10,0)/BY;
圓弧J:=IF(高天<低天,RN+YWJ,RN-YWJ),COLORYELLOW;
DRAWBAND(圓弧J,RGB(255,196,9),圓弧J,RGB(255,196,9));
YWK:=IF(XW<11*Y弧,SQRT(11*Y弧*11*Y弧-XW*XW)/10,0)/BY;
圓弧K:=IF(高天<低天,RN+YWK,RN-YWK),COLORYELLOW;
DRAWBAND(圓弧K,RGB(255,196,9),圓弧K,RGB(255,196,9));
YWL:=IF(XW<12*Y弧,SQRT(12*Y弧*12*Y弧-XW*XW)/10,0)/BY;
圓弧L:=IF(高天<低天,RN+YWL,RN-YWL),COLORYELLOW;
DRAWBAND(圓弧L,RGB(255,196,9),圓弧L,RGB(255,196,9));
YWM:=IF(XW<13*Y弧,SQRT(13*Y弧*13*Y弧-XW*XW)/10,0)/BY;
圓弧M:=IF(高天<低天,RN+YWM,RN-YWM),COLORYELLOW;
DRAWBAND(圓弧M,RGB(255,196,9),圓弧M,RGB(255,196,9));
YWN:=IF(XW<14*Y弧,SQRT(14*Y弧*14*Y弧-XW*XW)/10,0)/BY;
圓弧N:=IF(高天<低天,RN+YWN,RN-YWN),COLORYELLOW;
DRAWBAND(圓弧N,RGB(255,196,9),圓弧N,RGB(255,196,9));
YWO:=IF(XW<15*Y弧,SQRT(15*Y弧*15*Y弧-XW*XW)/10,0)/BY;
圓弧O:=IF(高天<低天,RN+YWO,RN-YWO),COLORYELLOW;
DRAWBAND(圓弧O,RGB(255,196,9),圓弧O,RGB(255,196,9));
YWP:=IF(XW<16*Y弧,SQRT(16*Y弧*16*Y弧-XW*XW)/10,0)/BY;
圓弧P:=IF(高天<低天,RN+YWP,RN-YWP),COLORYELLOW;
DRAWBAND(圓弧P,RGB(255,196,9),圓弧P,RGB(255,196,9));
YWT:=IF(XW<17*Y弧,SQRT(17*Y弧*17*Y弧-XW*XW)/10,0)/BY;
圓弧T:=IF(高天<低天,RN+YWT,RN-YWT),COLORYELLOW;
DRAWBAND(圓弧T,RGB(255,196,9),圓弧T,RGB(255,196,9));
YWQ:=IF(XW<18*Y弧,SQRT(18*Y弧*18*Y弧-XW*XW)/10,0)/BY;
圓弧Q:=IF(高天<低天,RN+YWQ,RN-YWQ),COLORYELLOW;
DRAWBAND(圓弧Q,RGB(255,196,9),圓弧Q,RGB(255,196,9));
YWR:=IF(XW<19*Y弧,SQRT(19*Y弧*19*Y弧-XW*XW)/10,0)/BY;
圓弧R:=IF(高天<低天,RN+YWR,RN-YWR),COLORYELLOW;
DRAWBAND(圓弧R,RGB(255,196,9),圓弧R,RGB(255,196,9));
YWS:=IF(XW<20*Y弧,SQRT(20*Y弧*20*Y弧-XW*XW)/10,0)/BY;
圓弧S:=IF(高天<低天,RN+YWS,RN-YWS),COLORYELLOW;
DRAWBAND(圓弧S,RGB(255,196,9),圓弧S,RGB(255,196,9));
漲點:=CURR=低天;
漲H:DRAWLINE(漲點=1,H,REF(漲點,1)=1,REF(H,1),0),COLOR00FF00;
漲L:=DRAWLINE(漲點=1,L,REF(漲點,1)=1,REF(L,1),0),COLOR8E00E8;
STICKLINE(REF(漲點,1)=1,漲H,漲L,0,0),COLOR00FF00;
跌點:=CURR=高天;
跌H:=DRAWLINE(跌點=1,H,REF(跌點,1)=1,REF(H,1),0),COLOR00FF00;
跌L:DRAWLINE(跌點=1,L,REF(跌點,1)=1,REF(L,1),0),COLOR00FF00;
STICKLINE(REF(跌點,1)=1,跌H,跌L,0,0),COLOR00FF00;
DRAWTEXT(CURR=IF(高天>低天,高天,低天),(圓弧S+圓弧R)/2,'震譜: 前高對今低 前低對今高 倍增加余數');
DRAWTEXT(CURR=IF(高天>低天,高天,低天),圓弧S,'飛龍軟件 飛龍軟件'),COLOR8E0000;
SY:=IF(XW<0.1*Y弧,SQRT(0.1*Y弧*0.1*Y弧-XW*XW),0)/BY;
震譜:IF(高天<低天,RN+SY,RN-SY),COLORFF00FF;
SYA:=IF(XW<Y弧,SQRT(Y弧*Y弧-XW*XW),0)/BY;
震譜A:IF(高天<低天,RN+SYA,RN-SYA),COLORFFFF00;
SYB:=IF(XW<0.25*Y弧,SQRT(0.25*Y弧*0.25*Y弧-XW*XW),0)/BY;
震譜B:IF(高天<低天,RN+SYB,RN-SYB),COLOR8E00E8;
SYC:=IF(XW<0.5*Y弧,SQRT(0.5*Y弧*0.5*Y弧-XW*XW),0)/BY;
震譜C:IF(高天<低天,RN+SYC,RN-SYC),COLOR8E00E8;
SYD:=IF(XW<0.75*Y弧,SQRT(0.75*Y弧*0.75*Y弧-XW*XW),0)/BY;
震譜D:IF(高天<低天,RN+SYD,RN-SYD),COLOR8E00E8;容


 
上下亂求索1☆ 簡睿震譜{源碼 主圖}
打開微信掃一掃,一鍵復制指標源碼,
輕松快捷粘貼至手機通達信APP中。
4

本站提示:股市有風險,入市請慎重,資料由股票下載網整理收集

找不到你要的公式?給我們建議

  1. 股票軟件
    股票分析軟件
    股票交易軟件
    股票行情軟件
    指標股票池
    手機炒股軟件
    書籍教程
    數據軟件
    工具補丁
    大智慧
    通達信
    飛狐
    東方財富通
    操盤手
    指南針
    分析家
    同花順
    錢龍
    證券之星
    券商股票軟件
    特色行情軟件
    迷你行情軟件
    金融界軟件
    美股外盤軟件
    大智慧股票池
    通達信股票池
    大智慧L2公式
    通達信公式
    飛狐公式
    同花順公式
    股票書藉
    視頻教程
    金融書籍
    其他書籍
    資訊評測軟件
    資金分析軟件
    數據接口軟件
    江恩波浪軟件
    數據下載軟件
    軟件數據投資
    選股軟件
    登錄補丁
    其他應用
    股軟教程
  2. 股票公式
    通達信公式
    大智慧公式
    飛狐公式
    同花順公式
    東方財富通公式
    金字塔指標公式
    文華指標公式
    MT4指標
    博易大師指標
    公式教程答疑
  3. 炒股知識
    短線技巧
    軟件公式
    炒股視頻
    股票入門
    股市實戰信息交流
    炒股技巧
    股票基礎知識
    技術分析
    炒股一招先
    基本面分析
    股票視頻教程
    股票買賣技巧
    k線圖分析
    胡立陽教你買股票
    短線炒股技巧
    天狼之眼
    波浪理論技術講解
    股市贏家楊百萬
    股票理論、T0纏論、知識
    經典指標、交易系統
    成交量能、籌碼分析
    買賣信號、技術分析
    挖坑、冼盤、吸籌、出貨
    均線戰法、黃金分割
    經典K線、趨勢形態
    牛股黑馬、王子理論
    漲停、周線、月線
    止盈、止損、支撐、壓力
    案例、波浪、口訣、選股
    分時、盤口、補倉、解套
  4. 技術指標
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR
30选7玩法